QNAP Q’Center change_passwd Command Execution

Facebooktwittergoogle_plusredditpinterestlinkedinmail

This Metasploit module exploits a command injection vulnerability in the change_passwd API method within the web interface of QNAP Q’Center virtual appliance versions prior to 1.7.1083. The vulnerability allows the ‘admin’ privileged user account to execute arbitrary commands as the ‘admin’ operating system user. Valid credentials for the ‘admin’ user account are required, however, this module also exploits a separate password disclosure issue which allows any authenticated user to view the password set for the ‘admin’ user during first install. This Metasploit module has been tested successfully on QNAP Q’Center appliance version 1.6.1075.

Facebooktwittergoogle_plusredditpinterestlinkedinmail